YFZ Central banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
first of all i apologize if this is posted in the wrong spot just joined the forum.

Hey y’all, i just picked up a 2008yfz450, cheap didn’t run great and smoked so i tore it apart cleaned carb and did valve seals, anyway i put it back together, put it in time, (can mod done) and the thing will not start. it will just crank and crank and never hit, not even off starting fluid. i’ve had it apart probably 6 times checking timing and make sure i did it all correct and i’m at my wits end with it.
Crankset Motor vehicle Bicycle chain Automotive tire Bicycle part

only problem i can see is the bearing retaining clips with the cap installed i can’t hardly turn the cams by hand i’m not sure if something is pinched, i don’t think so they slide on easy, and i can turn it over with a socket but i would think the engine would still fire right? all i get is an occasional backfire.
Automotive tire Engineering Gas Automotive wheel system Auto part

(also yes it’s getting great spark, fuel air and compression as it ran before i took it apart)
 

·
Registered
Joined
·
1,396 Posts
Forgive me a potentially silly question, but you're sure you're on the correct timing mark on the flywheel?

Those half-moon clips need to be in place, otherwise the cams will walk in the head. Do you know where those are? Did they fall down the timing chain tunnel into the stator area?

Regarding the cams being hard to rotate, You need to check to see if there's any galling on the head or the cam caps. If so, it needs to be addressed. If you just leave it, the cam won't have sufficient oiling in the area where galling is present, which will guarantee failure again quickly.

I'd suggest double and triple checking your timing marks, and going from there. Best of luck.
 
1 - 2 of 2 Posts
Top