YFZ Central banner
1 - 2 of 2 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter · #1 ·
So it was about 25 degrees today and my YFZ didn't want to start. The battery was a little low and it would crank kind of slow suspected dead battery because it cranked a little slow and then it would crank really slow one revolution at a time. I then hooked a battery charger to it and it fired instantly with full choke. It ran on full choke then started to not idle as smooth after about 30 seconds with the choke on as it usually does. Then I pushed it to half choke and it began to run better then did the same thing. If I push it to no choke it will not idle at all and will die. It started back up on no choke right away. If I push the throttle it doesn't want to take the gas to well but will idle once it's warmed up a bit on no choke. Idles fine with no choke on but will not take the gas to well. I have my airbox lid removed also. It usually runs and starts up good when it's cold but idk what happened today maybe it was just really cold but idk what. It also hiccuped in the carb for the first time today. Doesn't do that usually??
 

·
Registered
Joined
·
1,117 Posts
Battery is a big thing.But richen the jetting up or I find just putting a closed airbox lid setup if its currently modified works pretty good to.That is if your jetting is on before the cold.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top