YFZ Central banner
21 - 37 of 37 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #21 ·
Mine did the same thing. Its a lack of fuel getting to the bowl. Check and adjust the carb floats!

Yeap, we replaced the carb from another YFZ, it has the same exhaust but stock CDI - so that's checked already. But we will check the floats. Thanks for your input.
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #22 ·
Try the jetting suggestions first.

I thought there was a thread about the carb's fuel float not being set right. 9mm is the height. That fixed his issue which sounds like this issue.

Not sure how to test it, but maybe the valves are worn out? It is 3 years old.

Just thinking out loud.

Checked and checked ;/

Thanks for input, at this stage I'm happy to hear any comments. even is some things it might be senseless
 

·
Premium Member
Joined
·
3,873 Posts
we had a bike that kept cutting out a tryed everything we could think of. one night we swaped harnesses with another bike and the cutting out stopped. never did take the harness apart to try to find out why though. just ordered another one
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #24 ·
we had a bike that kept cutting out a tryed everything we could think of. one night we swaped harnesses with another bike and the cutting out stopped. never did take the harness apart to try to find out why though. just ordered another one

Yeap we've done that. Thanks.
 

·
Registered
Joined
·
1,819 Posts
What did my jetting suggestion yield?
 

·
Registered
Joined
·
193 Posts
I'm leaning towards jetting as well especially if you've swapped everything else out. Start with some good base line jetting like you've been given and just mess with one circuit at a time go bigger until it sputters and then back it off to the previous point. When you mean cuts of do you refer to like it just hits a flat spot and won't keep accelerating to the rev limiter? That's a lean condition its starving for fuel
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #27 ·
What did my jetting suggestion yield?

Same ;/

However, we took the cover from the air filter and ride without it - and there is an improvement !! The cut of point is at higher revs than before.

We recokon that fitting KN filter would help ? Please let me know what you think guys !
 

·
Registered
Joined
·
1,819 Posts
Sure or get the proper jets in there. Are you able to take it to a dyno?
 

·
Registered
Joined
·
137 Posts
yea mine did that it does it alot worse with the lid on but when you put it on its not as bad....hmmmm maybe higher octane race fuel?
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #31 ·
yea mine did that it does it alot worse with the lid on but when you put it on its not as bad....hmmmm maybe higher octane race fuel?

You reckon that will help ? Race fuel is not that popular in EU. I'm not even sure where to get it from.
 

·
Registered
Joined
·
334 Posts
if u got the quad from some one else they maybe put a higher comp piston in with you knowing and had to put in higher octane fuel in there? i dont know just throwin somethin out there
 

·
Registered
Joined
·
178 Posts
I'm thinking jetting or stator. You may have changed it but Ive bought new ones that were bad. Just sayin. BTW what it TORS
 

·
Registered
Joined
·
1,819 Posts
Throttle over ride system. So if your slide in the carb is open but thumb throttle is closed it will kill ignition
 

·
Registered
Joined
·
1,819 Posts
Adding the k&n is just changing jetting. Jet to what you have now! Unless you wanted a k&n
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #36 ·
Adding the k&n is just changing jetting. Jet to what you have now! Unless you wanted a k&n

Fair enough, just thought more AIR would help. Thanks for all the input, guys. I'll play with the jetting and will let you know if that helped or not.
 

·
Registered
Joined
·
1 Posts
Checked and checked ;/

Thanks for input, at this stage I'm happy to hear any comments. even is some things it might be senseless
Have you changed the coil and spark plug wire. Mine would rub fine for about 10 minutes or less then start banging out. I have 07yfz450.
 
21 - 37 of 37 Posts
Top