YFZ Central banner
1 - 11 of 11 Posts

·
Registered
Joined
·
535 Posts
Discussion Starter · #1 ·
So I wanted to take a look at the plug on my 14 to see if I could get a better reading on my setup. When I pulled it out I found it was all rusted. Now I just bought my bike in July and don't think it should look like this lol.
Do you think the head can be screwed up as well?
 

Attachments

·
Registered
Joined
·
51 Posts
Rust is only on outside of plug just comes from washing. But its showing signs of being rich. Which is not a bad thing just prone to fowling plugs faster. Id rather be rich than lean. I assume you are running a fi controller may want to play around with your settings a little. You can go a little leaner to make more power but be careful not to go to extreme. A lean plug will be white its had a lot of heat on it.....But if that's oil on your plug you have a ring problem...But from the pic just looks rich doesn't look like oil deposits.
 

·
Registered
Joined
·
535 Posts
Discussion Starter · #3 ·
Yea I was speaking more of the rust not the rich issue. I have a vortex and I will drop it down a click on the hi. I was at 7 originally then last week dropped it to 6 and today I will try it on 5. I was more worried on why a plug on a 3 month old bike could have rust like that.
 

·
Premium Member
Joined
·
3,631 Posts
If it's running good I'd rather be rich than lean any day!
 

·
Registered
Joined
·
55 Posts
I've had the same problem with my spark plug on my bike. I have an 06 yfz and due to the spark plug being set pretty deep in the head, water gets tramped in there really easy after washing. It tends to dry up once you ride your bike right after. however if you let it sit after washing thats where the rust comes into play.
 

·
Registered
Joined
·
535 Posts
Discussion Starter · #6 ·
I've never seen something rust that bad in 3 months.
Yfz madness I agree it is running good I would rather be rich too I have just been trying to dial the. Or tex on by hand and wanted to make sure I wasn't too lean and when I saw the rust it puzzled me a lil bit.
 

·
Registered
Joined
·
637 Posts
That does not show the bike is rich!!!! If he let the bike idle before shutting it down, the plug could look black, without being rich.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top