YFZ Central banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,563 Posts
Discussion Starter · #1 ·
well my bike still isn't jetted properly, i still get some popping and some flames out the exhaust every now and then, havent bothered cause i plan on dropping in the yz450f cam sometime this week or next and a air filter kit, when my bike i stopped i can rev it up and when i get way up in rpm's white smoke will come out of my exhaust, not a cloud but noticeable if in a not so bright room, im sure it does it while riding to but i cant see it when i look back, my question is, can this be cause of my jetting issue or do i have other problems going on, also while replacing the compression plug on top of the header i noticed some antifreeze on the stock engine skid plate, where can this be coming from?
 

·
Registered
Joined
·
921 Posts
:rock first of all it is toatly normal for alittle bit of smoke to come out when u first start it, mine does it, but like u said its hard to notice, an the antifreeze u are talkin about is from your inpellershaft, if u bring it to your dealer yamaha will cover it, the parts are only like 100 bucks if u wanna do it yourself, my dealer charged yami 450 bucks to fix it, all i can say is keep checkin your fluid lever if u keep riding it, i rode mine with it leaking for 1.5 months, an only lost about half cup antifreeze. i hope this helps u :yfz
 

·
Registered
Joined
·
1,563 Posts
Discussion Starter · #3 ·
thanks for the reply, as long as im not burning oil im happy :lol i havent noticed if it does it after riding for a while, i will try it later on, and why odes the impellershaft leak? is this a factory defect or something causes it
 

·
Registered
Joined
·
921 Posts
Yes i think it is a factory defect because alot of peoples yfz have , or have had "thedrip" , bring to your dealer an have em fix it, go in here an look up "antifreezeleak" an u will see all of our posts an the yamaha numbers to call an get the parts ship, they will know what your talkin about when u tell em your leaking antifrezze,im not sure what cause it! Mine did after 1month, if your clutch cable hasnt snaped yet u might wanna order a new one, along with some new tires, the front ones are paper thin...later :rock :yfz
 

·
Registered
Joined
·
1,563 Posts
Discussion Starter · #5 ·
tires are all taken care of :D , as far as the clutch cable goes, is there an aftermarket one that is better then stock?
 
1 - 5 of 5 Posts
Top