YFZ Central banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 · (Edited)
Finally bought new house and got YFZ out of storage from my buddies house. I unfortunately didn't do anything prior to storing it. It turned over, but never got it to fire. It is 2006 YFZ totally stock besides Zip Tie Mod, K&N closed air box & no spark arrestor. I would guess about 30-45 hours total.

I've changed:
Oil/filter (Smelled like gas)
Drained/replaced gas
Replaced spark plug.

Still wouldn't fire so I now have the carb apart and the bowl was terrible.

Was planning on:
Rebuild the carb
Replace the leak jet with a 35 (I bought years ago)
New petcock on gas tank
New adjustable A/F screw.
Thinking about the oil mod...

I'm assuming I'll have to rebuild the top end because of the gas in oil, but with the bowl etc being so bad, is there a chance it was just that? I've read a bunch of posts and it didn't sound good. Any other recommendations? I'm not a racer, just like to have fun. I just want it to run.
20210425_123807.jpg
20210428_232710.jpg
 

Attachments

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
It used to run great before it sat in the garage.. When I fired it up occasionally it got harder to start/run.

So the last couple weeks I've rebuilt the carb etc. It did start up and ran but the throttle was getting hung up and wouldn't lower to idle and was back firing. It also wanted me to give it throttle to start it with choke on. I tried to adjust idle and fuel screw but didn't change much. I messed with it today and it wouldn't start without throttle, and now it won't idle, it just dies. So I'm taking it off again.

I made the mistake of not taking the throttle plate out and cleaning it/ replacing the gasket before. I'm also going to throw a new accelerator pump on.

The stock jets were
40L 42P 90S 155M stock needle now
35L 48P 90S 155M new needle one position
Had fuel 2 turns out
 

·
Registered
Joined
·
45 Posts
It used to run great before it sat in the garage.. When I fired it up occasionally it got harder to start/run.

So the last couple weeks I've rebuilt the carb etc. It did start up and ran but the throttle was getting hung up and wouldn't lower to idle and was back firing. It also wanted me to give it throttle to start it with choke on. I tried to adjust idle and fuel screw but didn't change much. I messed with it today and it wouldn't start without throttle, and now it won't idle, it just dies. So I'm taking it off again.

I made the mistake of not taking the throttle plate out and cleaning it/ replacing the gasket before. I'm also going to throw a new accelerator pump on.

The stock jets were
40L 42P 90S 155M stock needle now
35L 48P 90S 155M new needle one position
Had fuel 2 turns out
Make sure you don’t have an air leak/leaks on the boots that connect to the carb, that could also be the reason why it hangs idle like you were saying. and the top end you don’t need to rebuild unless for some reason it has little compression, but it’s just been sitting so you shouldn’t need to.
:cool:
 
1 - 5 of 5 Posts
Top