YFZ Central banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,024 Posts
Discussion Starter · #1 ·
ive ridden my yfz a total of 5 times now. it has 8-10 hours on it.
my problem is the battery feels weak. it hasnt failed to start yet, but its not turning over like i feel it should. i heard from someone it was a stator problem, and yami may have a recall. anyone else having this trouble?
 

·
Registered
Joined
·
111 Posts
Did you guys check the battery bolts yet?? They might have losened up that would cause it not to start sometimes, and sometimes it would. I have had mine july and haven't had any problems. I also do not have lights on mine. :what
 

·
Registered
Joined
·
1,024 Posts
Discussion Starter · #4 ·
i checked the connections and thats not the problem. i understand its a stator problem, and that riding with the lights on will cure it. im gonna try it this weekend.
 

·
Registered
Joined
·
9,372 Posts
lights arent connected to the battery........ so that aint it......hav u dun the cam mod? ive heard people having problems after doing that
 

·
Registered
Joined
·
1,024 Posts
Discussion Starter · #6 ·
i havent done the cam mod. i have ben told the stator puts out too much power which overloads the battery. and, if you run with the lights on, b/c the lights run off the stator it cures the problem. i ran it this weekend for a couple of hours with the lights on and had no problem as long as i was in neutral when i tried to start it
 

·
Registered
Joined
·
73 Posts
I am hearing the stock battery is putting out 85 CCA. There are outer batteries and I was given the number of a battery that puts out 125CCA. I have not tried it yet but makes sense the more CCA the better for starting. :lol
 

·
Registered
Joined
·
625 Posts
I have decided that the nature of the modified beast is you have to give it a little gas to get it to fire when it is hot. I can live with it. I am not mx'ing it so if it takes a few tries to get it to fire when it is hot I can deal.
Isaac
P.S. doesnt mean I am not rushing out to buy a new battery though. :) :sup
 

·
Registered
Joined
·
453 Posts
there is an artical in the new dirt wheels about the z 440, predator, and the yfz and they said the had a battery prob. at the dunes and after they installed a new batt. they had no more problems after that :re
 
1 - 12 of 12 Posts
Top