YFZ Central banner
1 - 9 of 9 Posts

·
Registered
Joined
·
209 Posts
Discussion Starter · #1 ·
I just took my yfz out for the first time in a few month and it really seems to be lacking in power? The engine runs perfect but I can punch the throttle and the front end wont even come up with my leaning all the way back. It was somewhat the same when I got it but it wheelied easier. i got it used so i dont know how many hours are on the clutch, but when i first got it and hammered on it and took off hard. Now its just like riding a 400ex :icon_eek: I know theres more than 40 hours on this clutch from just me easily, but I dont really beat on it bad. So what is the cheapest and best route to go for a new clutch? Should I get just plates or springs with it?
 

·
Registered
Joined
·
329 Posts
Are you sure your clutch is slipping? Can you hear the motor reeving more than your going? Maybe your filter is dirty or your carb is partially plugged? I would check all of this first. Another thing is maybe your just used to the power of the quad and its starting to feel slower.
 

·
Registered
Joined
·
1,105 Posts
i would get new springs too if it is the clutch. as far as clutch oem or we just put a kb in my bros warrior and have had really good luck with it. i heard they make some of the oems
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #4 ·
Well now the snows gone and im fully convinced something is wrong. The engine runs fine, revs up fine and everything. I know what a slipping clutch is like but this dosent SEEM like it, well it dosent feel like it. When You hammer on it it does take off decently but not like a yfz should. I was riding with an old yami 225dx today behind him and when I punched the throttle it took quite a while to catch up. And this thing tops out at 55 no lie, And the gearing is 14/38. The engine was just rebuilt and runs excellent but the top end is HORRIBLE. Wtf is up with this thing? Only thing I can think of now is something is dragging like bearings or something else. I also got the jetting dialed in perfectly.
 

·
Registered
Joined
·
73 Posts
You said it was sitting for a while, possibly bad gas. Check the plug and see what it looks like. You may want to add some stabil to the gas to try and freshen it up, or just drain it.
 

·
Registered
Joined
·
168 Posts
Easiest way to tell if you need a new clutch is to strap the quad on a dyno. If your clutch is slipping it will be even more obvious when strapped to the rollers. Also if you change the oil, ride it for a few minutes and then check the oil, if you have a bad clutch, the oil will turn black almost instantly. This is from the fibers and the extra heat that is being generated by the slipping plates. If you don't have access to a dyno, just open the clutch case cover and inspect the plates. On my last clutch replacement, the fiber plates looked pretty good (but discolored), but the solid plates were black and almost had a gold sheen to them from being glazed over from the heat generated by the slipping clutch. Extreme heat can also deform the springs to the point that they will no longer be within tolerance.
When replacing a clutch, replace tthe entire thing! Don't be a cheap a$$ and just replace the fiber plates, the solid plates, or just the springs. Stock clutches work very well and are almost always cheaper than aftermaket. Remember to soak the new plates in fresh oil for several hours before installation.
 

·
Registered
Joined
·
26 Posts
dude... ive been posting about the same thing.. "wtf is wrong with my yfz" .. man i thought it might be because the roads were wet... but yea dude.... def the clutch.. i got a clutch on rockymoutainatv.com ?? i think thats the page... 40 bucks.. and i bought the gasket.. put it in.. works great!!!!!! its def the clutch... mine would be fine for like 10 min.. i could ride wheelies.. and take off real fast.. after about ten minutes.. its like i was peeelinng out .. engine would rev loud... alot of rpms no movement.. lol its ur clutch.. i think the clutch is called a tusk... i read some reviews.. supposeably its a bad ass clutch for the $$$$
 

·
Registered
Joined
·
209 Posts
Discussion Starter · #9 ·
I will take the cover off and look at it tonight. But the thing is i cant feel any slipping at all. It will burnout on pavement and hit the rev limiter easily but the easiest way to explain it is it has no balls.
 
1 - 9 of 9 Posts
Top