YFZ Central banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
1,214 Posts
Discussion Starter · #1 ·
Yup.....I took the bolts out of the neck holding it above the radiator. I removed the large carter pin, and nut from the bottom, and it still won't budge. I looked up inside to see if there was a snap ring, but I couldn't see one. SO what's the trick? Is it threaded in? pressed in? My column still feels like it has good movement in it, so it's not binded anywhere.

What's the deallio?

Thanks.
 

·
Registered
Joined
·
194 Posts
The end of the shaft and the plate, (the plate that the tie rod ends mount to) are splined.

When I bent my shaft, I had a hard time getting the plate off, once I did I found out why. The splines on the stem twisted when I crashed, so the plate didnt slide off easy like it should have.
I had to pry on the plate to get it off.
Just use alittle force, and it will come off.
 

·
Premium Member
Joined
·
1,214 Posts
Discussion Starter · #3 ·
Oh yeah...forgot about the plate......it's also off of the stem. :wtf

any other suggestions? :(
 

·
Registered
Joined
·
194 Posts
Thats all there is to remove, so I would guess, that for whatever reason, its sticking to the bearing, and needs a little help coming out. Have you tried a hammer??? :disgust
 

·
Registered
Joined
·
85 Posts
I am doing mine this weekend. Finally something has come in.
 

·
Premium Member
Joined
·
1,214 Posts
Discussion Starter · #6 ·
Yeah I already tried the hammer, but I have a full skid on the bottom, so I may have to remove it and break out the Big Fuk'n Hammer cause we even tried yanking on it, but it ain't comming..... :uhoh
 
1 - 8 of 8 Posts
Top