YFZ Central banner
1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hey guys I have a 09 yfz 450r. I was riding and it randomly died on me. when I tried staring it the battery makes a buzzing noise. the quad is also throwing trouble code 12 crank position sensor and 15 no throttle signal I can't get these codes to clear I tried turning the key 3 times. I heard it can also be rollover sensor I took the cover off that surrounds the tail light and the rollover senor does have a rattling noise when I move it. Should that senor be replaced? The battery has over 12 volts before I start it and when I do start it drops to 11.6. my buddy has the same quad and we tired swamping batteries, and my battery wouldn't start his quad wouldn't turn over or crank and his battery in my quad just had the same problem it was making a buzzing noise which is weird. The spark plug is fine solenoid is fine fuel pump is working and starter. I have a fmf exhaust with power commander fuel optimizer.
 

·
Registered
Joined
·
219 Posts
id guess it to be a harness problem myself, thats probably where id start anyway... wires could have rubbed through and shorted, and messed up your battery.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
I got all of the codes to clear the problem that I'm still having is it won't fire. its getting spark fuel pump is working and getting fuel into the motor it will crank over just nothing coming out of the exhaust won't fire. don't think its electrical problem the battery is charged thinking its something in the motor
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top