YFZ Central banner

1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
2018 Yfz450r - Anyone else with newer yfz have stalling issuesRiding slow but still moving (1st gear) frequently the bikes just stalls out.
Also from a complete stop I have to punch it otherwise just dies - gets really frustrating.
Is this just part of the bog issue or could be something else?
 

·
Registered
Joined
·
12 Posts
Yes, I believe it is part of the bog issue. I have loading ramps, and stock I would notice I would need to rev - clutch - rev just to get it loaded into the truck without it stalling out. I purchased/installed full HMF Comp pipe, HMF Tuner(Dobeck), K&N filter with open lid and using HMF's recommended tuner settings has eliminated the bog. I noticed this especially when loading my quad and didn't have to rev/clutch it just to keep it from dying. I'm not recommending this particular setup, more so recommending an aftermarket pipe/tuner to relieve the bog issue.
 

·
Registered
Joined
·
1,527 Posts
2018 Yfz450r - Anyone else with newer yfz have stalling issuesRiding slow but still moving (1st gear) frequently the bikes just stalls out.
Also from a complete stop I have to punch it otherwise just dies - gets really frustrating.
Is this just part of the bog issue or could be something else?
What altitude u ride at in your bone stocker? If it is that bad like really bad order the tps harnezz from peak racing products and set tps angle correctly.

My bone stock 2018 yfz has the bog too but not that bad only once in a while i notice it. I ride at about 2000 feet in elevation.

Vortex coming soon after nerfs and truck repairs. Wa wa wa waaaaaa



Sent from my LG-LS997 using Tapatalk
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
it has Pro Circuit T-4 exhaust pre installed by dealer when I bought it and to my knowledge has factory fuel controller. I live and ride in Las Vegas and surrounding areas 2000-2600ft elevation.
And yes I have the same issue getting loading onto trailer/truck.
 

·
Registered
Joined
·
1,527 Posts
U got the airbox lid on right? U sure OEM ECU did not get FLASHED to squirt more fuel?

Sent from my LG-LS997 using Tapatalk
 
1 - 6 of 6 Posts
Top