YFZ Central banner

1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I just bought a 2010 yfz450x BB a month ago and noticed my radiator fan or the fan located directly behind the radiator has never kicked on, never ran or heard or seen it run. Does it only kick on at a certain point or how do i test to see if it does work and a fuse isn’t bad??

Any suggestions would be great.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
871 Posts
It only kicks on beyond a certain temperature, I think like 190 or 200 or something. There is a relay for it underneath the hood you can check. Also, check to make sure you have an OEM key switch and not a junk replacement.
 

·
Registered
Joined
·
51 Posts
erbear321, be careful. These bikes run hot. Personally I think that cooling upgrades are well with the time, effort, and expense. Frankly, with engine mods and increased HP, they are required. We have many cooling upgrades on our bike and even installed a digital temp gauge to accurately monitor temp.

We own a 2007 450 but if your 2010 450X has the same cooling wiring circuit and it has been left in stock condition, it has a circuit breaker and the temp relay that Silsby mentions above. Check both. Check all of the associated wiring. First, test the fan with 12V directly applied to be certain it is functioning. Good luck.
 

·
Registered
Joined
·
1,443 Posts
I used to think my 18 R fan never kiked on. When i 1st rode snow covered uphill trails with OEM tires i would get slowed down and the FAN KICKED ON. THATS WHEN I 1ST KNEW EVERYTING WORKING AS ADVERTISED. I bet the fan wont come on with the razr 2 rears as they some beefy deep tread MOFOS SPECIALLY WITH A RIGHT THUMB HUNGRY OPERATOR.

Sent from my LG-LS997 using Tapatalk
 
1 - 4 of 4 Posts
Top