YFZ Central banner
1 - 17 of 17 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Can someone please help me!? I just bought an 04 yfz 450. Starts and idles fine. It rides fine until about half throttle. When you get on it from 1/2 throttle and on the bike wants to cut out and bog out. I just took the carb apart today and we cleaned and put new Jets in it.i think it still needs bigger Jets. Pilot is stock because it idles and until half throttle does good. Main is a DJ165. Biggest dynojet sent me. Clip is in the middle. A/f screw 2 out. Can someone please help me with the jetting or have any ideas why this could be happening. Also my fuel screw I noticed came completely out while trying to ride it after installing. Also added build list of bike.
D65CDB0C-28C8-49F5-A4E5-284B63A6CE3D.png
 

·
Premium Member
Joined
·
827 Posts
I would reach out to the maker of the exhaust and see what they recommend for base jetting. 165 for a bone stock piped motor with no lid is often too small.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
It has a 200 in it now. I don't think this is jetting . I think this is electrical or something. The motor completely falls on its face after half throttle.... Straight cuts out. Runs strong until half..what could this be ?? The wiring harness looks like crap. Race cut.. not by me. Has no headlights. Has no resistor.
 

·
Premium Member
Joined
·
827 Posts
200 is beyond too big and you are for sure running rich. The biggest built bikes don't usually get beyond 180. Electrical issue are possible and old 04's had known issue that's why people rewired them.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #6 ·
Okay I'll try going down. But man it runs so good until you hit half throttle and it falls on its face... Every gear. I thought about getting a resistor. By rewiring what do you mean ? Just rewiring the whole harness ?? There might be bad wires and stuff ?? Could this be just bad wiring ?? Or could it be cdi too?? We checked stator and it seemed okay. My plug didn't look bad. Maybe old. But the connector looked bad up inside. I'm just lost on where to start.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
Also could you give me a idea on jetting according to build posted in pic ?? Rn it's stock pilot . 200 main. Clip in middle.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
Also it has a Sparks exhaust and it definitely needs repacked. Pieces of packing are blowing out the tip.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
I got this on a trade and I'm gonna fix it all up I just need to know where to start on the cutting out.
 

·
Registered
Joined
·
3 Posts
Mine was the exact same way , i went to a 120 jet it got better , everything else was to big and i took breather lif off it's way better, but it's gotta be electrical i changed stator and rectifier now my quad won't even crank!!!
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #12 ·
I'm gonna try rewiring and a resistor. Probably a new coil and plug. This is so confusing that the bike runs perfect then outta nowhere when you get in higher rpms it just wants to die. It is so weird. It almost has to be electrical.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #14 ·
So do these batteries need an extra source pulling power for then to run right ?? I'm new to the yfz scene. I've read everywhere that u have to run with the headlights on?? And mine have been removed and plugs cut from the harness
 

·
Premium Member
Joined
·
827 Posts
its hard to say the root of the issues but the wrong jetting can do all sorts of things that are very similar to your issues.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #16 ·
It ended up being jetting. I had to go way lower in Jets that I would have ever thought. I figured I'd post because alotnofnpeople don't post what fixed their issue
 

·
Super Moderator
Joined
·
3,132 Posts
What did you end up going with on the jets?
 
1 - 17 of 17 Posts
Top