YFZ Central banner
1 - 11 of 11 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
Alright I got a question.
Put a pro circuit t4 slip on pipe on the yfz and also a motion pro twist throttle. It will start and idle but when I give it gas it just shuts off?!?!?! Does anyone know what is the problem. Also what jetting should I run ??? I am around 2000 ft elevation......
 

·
Registered
Joined
·
77 Posts
gotta be the jetting..i ripped the baffel outta mine and it likes 2 stall alot or when i give it gas it kicks off.....def the jets though
 

·
Registered
Joined
·
1,024 Posts
put the stoke pipe back on and she if it runs. if it runs fine w/ the stocker, then you need to rejet b4 you run the pc pipe. if it wont run with the stock pipe on then you f***ed something else up when u installed the twist. good luck!! and read the threads on jetting....god, there must be 1000 on here..
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #4 ·
Got it working. Had to soldier a couple wires together because of the twist throttle but its running fine now :)
 

·
Registered
Joined
·
143 Posts
How do you like the twist throttle? I'm thinking of getting one for mine.
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #6 ·
I like twist throttles alot better than thumb throttles but that is just me. I am used to riding bikes and find it less tiring(sp) riding with a twist throttle. Also long rides are alot easier with a twist throttle I think :)
 

·
Registered
Joined
·
9,372 Posts
Originally posted by CHAUNCY@Oct 9 2003, 03:41 AM
I like twist throttles alot better than thumb throttles but that is just me. I am used to riding bikes and find it less tiring(sp) riding with a twist throttle. Also long rides are alot easier with a twist throttle I think :)
WHO GIVES A FLYING F***.... :lol j/j man..... glad you got it working
 

·
Registered
Joined
·
634 Posts
Originally posted by CHAUNCY@Oct 8 2003, 11:49 PM
Alright I got a question.
Put a pro circuit t4 slip on pipe on the yfz and also a motion pro twist throttle. It will start and idle but when I give it gas it just shuts off?!?!?! Does anyone know what is the problem. Also what jetting should I run ??? I am around 2000 ft elevation......
you need a 48 pilot jet airscrew on 1.5 stock needle on 6 and mainjet 170 with that setup

then your quad will run.
 

·
Registered
Joined
·
634 Posts
PLEASE GO READ THE MANUAL on the THROTTLE SENSOR I think it is section 9-7 or 9-9 in the Yamaha YFZ450 REPAIR MANUAL.

You probably knocked the TORS sensors out of wack

It is an easy fix if you know about it,

or just take it in to the shop and theyll charge you about 80 bucks to fix it.


careful about yanking on those throttle cables.


also rejetting is an issur just put in a 175 main jet and put your needle on clip #6 from the fat end (move it 2 towards the skinny end) on your needle jet and put in a 45 or 48 pilot.

then your set to go.
 

·
Registered
Joined
·
1 Posts
I just got my new Motion Pro Twist for my YFZ, but I'm unsure as to what to do with the Throttle Position Sensor. The Motion Pro does not have an area for these wires. I read earlier that someone soldered them together. What's UP???
 

·
Registered
Joined
·
1,461 Posts
I talked with Joe & Larry at Motion Pro, and they told me in the old version of the directions, they forgot to include the section on what to do with those wires coming out of the thumb throttle.

Simply cut the wires off the thumb throttle and connect them with a wire connector. At their suggestion, and since I had the plastics off my quad, I cut the wires closer to the wiring harness, then tucked it into the harness protector. In the end, you just simply need to make sure the loop is maintained.

If anyone would like an emailed copy of the new direction explaining this process which is now included in the Motion Pro kits, email me at [email protected]
 
1 - 11 of 11 Posts
Top