YFZ Central banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello guys I’m having a problem with my 2007 YFZ 450 hopefully someone can answer my problem thanks in advance so my quad is turning the red light even tho the radiator have coolant and the over flow tank have coolant fan always on but when I finish riding over heating tank is empty it’s my first quad so I don’t have much experience just need a heads up so I don’t go spending money on things that I don’t need
 

·
Registered
Joined
·
216 Posts
I’m might be wrong but I thought the red light was oil light.

Low on oil, bad oil pump, bad sensor.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I’m might be wrong but I thought the red light was oil light.

Low on oil, bad oil pump, bad sensor.


Sent from my iPhone using Tapatalk
Well I got my oil change few days before going on a ride and only thing I saw when the light came on was that the coolant over flow tank was empty but checked radiator and it had coolant I filled up again and still was empty after I checked again
 

·
Registered
2008 YFZ450
Joined
·
3 Posts
Had this same problem on my 08. What fixed it for me was I completely removed the rad from the quad, and drained it. I then did a very deep clean with brushes and water, crazy how much dirt was left in there. I let it dry then put it back in and my problem went away. It was a little time consuming but worked for me. Good luck!
 

·
Registered
Joined
·
105 Posts
If your coolant overflow tank was empty, make sure the oil doesn’t have any coolant mixed with it. Also, make sure coolant isn’t leaking from the weep hole below the water pump housing.
 
1 - 6 of 6 Posts
Top