YFZ Central banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I went and changed my oil yesturday which I do often but realized my oil want pumping through the motor. Realized this by starting the motor then shutting it off and checking the oil and it didnt lower at all like it should. To make a long story short when I first got this I kept beating up stators I fixed that issue and thought I got all the pieces out of the motor but guess I was wrong. There is still a bunch of crap in there and I believe its blocking oil passages. And tips on how to get all this crap out without ripping the hole motor apart
 

·
Premium Member
Joined
·
696 Posts
If this a carb model pop off the external tank and hoses and clean the screens on the ends. If this i an R you might be able to clean out the bottom by popping off the clutch side cover and see if anything is visible in the bottom.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
It's an 2010 x BB edition. So yea nothing external to get to. I did pop off the side cover when this first started and a bunch of gasket sealer setting in there from previous owner plus some plastic from stator still in there from when I had that issue. I cant seem to reach it all any ideas
 

·
Registered
Joined
·
963 Posts
You're not going to like it but I have seen if you take the motor out and take the side cases off you can run some oil through the bottom and work it around (motor in your hands) to get any pieces in there out. But it is a lot of work.
 

·
Premium Member
Joined
·
696 Posts
That is not going to be easy. If you sucked that much crap into the screen you might not be able to get it all out without lots of work. I'd get myself a cheap scope and look into the bottom end.
 

·
Registered
Joined
·
187 Posts
How many screens are ther?
A oil pick up screen? And a screen in the oil tank?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Yea that's what I figured . And I believe it only had the one screen which is located towards the back it's right behind the oil plug to the back of the motor nit the one in the front. But I could be wrong about only being 1 screen
 
1 - 7 of 7 Posts
Top