YFZ Central banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello everyone sorry if this is repetitive but have not found anything that directly answers my question. I have a 2014yfz450R that just got wrecked and im rebuilding it. However when trying to plug the oem taillight i cant seem to know where to plug it to. So im wondering if the original plug got ripped off during the wreck or im hust not seeing it. Any pictures would really on where the tailight is connected to. Thank you in advance for all your help and sorry for such a simple question but i cant seem to figuere out if im missong something or not. The part number is correct so i seem to have the correct taillight. Here are some pix of the plug on the quad and the tailight plug.
 

Attachments

·
Super Moderator
Joined
·
3,975 Posts
See the hook in the tail light cover on the left side? That is where the cord is pushed into and that sure looks like the correct plug. Pull it and plug it in and it should work! Also you may want to get some felt pads or foam to put on your tail light where it is going to vibe on the tail light cover to keep it from getting rubbed away. Ace Hardware has stuff in the table leg area....Lowes used to have little foam pads with tape on one side that were awesome for this use and they last forever....

 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
So you saying that the connector coming out of the quad is a 2piece and should be dusconnected in order to plug the new tail light in?. Im posting a pic with a red circle on the piece i think your saying is a 2 piece and needs to be disconnected in order to connect the new taillight in.
 

Attachments

1 - 6 of 6 Posts
Top