YFZ Central banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Just did an oil change and when I took the oil filter out I found lots of metal shaving. It definitely doesn’t look good. It been about 5 hours since my last oil change. I always use Yamalube 10w-40 What would cause this?





Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
It means that oil is not moving freely within the vital engine components. Metal shavings in the oil prevent the smooth flow of oil in the engine. Eventually, when your engine stops getting lubrication in some parts, it stops functioning well.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
How many hours on the motor? I’d look into getting some magnetic drain plugs do the oil change and run it and see what you end up with.
I don’t have an hour meter so it’s hard to say, I also picked it up used. I would say it probably has 70-100 hours on it now based off condition. I’ll look into getting a magnetic drain plug, which one would you recommend?


I would inspect your clutch bolts. Your basket could be flying apart.
I’ll have to pull my clutch cover off and see! Thank you.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
49 Posts
Can't be certain, but to my eye, that metallic debris in the oil filter looks like it might be aluminum. I like uusing magnetic plugs but they are not going to help with aluminum debris. When you inspect the clutch components, pay close attention to the bearing surfaces on the inner hub and pressure plate.
 
1 - 7 of 7 Posts
Top