YFZ Central banner

1 - 6 of 6 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
My 04 will not stop leaking coolant. It leaks from the pipe that the radiator hose is connected to. There is an o ring in there I replaced that I thought would fix it but didn’t. I changed every seal and bearing even a new impeller shaft.
It’s not leaking from the weep hole but actually where that little pipe goes into the water pump cover. And when I say leak I mean it’s hardly dripping at all. I am tempted to put some silicone on the small pipe to help that o ring seal better but don’t want to if it will damage anything. Any ideas or opinions or experiences will be helpful.
Thanks
 

·
Registered
Joined
·
14 Posts
leaking from the leak off pipe is a common problem with a carb model yfz450 but it sounds like you have replaced all of the internals, where the metal pipe is pressed in to the housing might be corroded. i would recommend getting your hands on a 2nd hand housing and put all your new parts in to it and see if that does the trick.
 

·
Registered
Joined
·
77 Posts
Discussion Starter #3
I have quite a few extra parts and I used the cleanest water pump cover and the pipe that comes out of it. I cleaned it up perfectly both pipe and housing. I feel like if that is the case and it is not sealing good so it’s seeping out silicone or something along those lines could do no harm.
 

·
Registered
Joined
·
14 Posts
If your pipe is handy to remove from the cover i would try removing it cleaning it again then bonding it in with a liquid metal or something similar that is heat and chemical resistant
 

·
Registered
Joined
·
3,085 Posts
Pull the pipe and look for corrosion or build up.
Did you replace that little fork and tube?


Sent from my SM-G970U using Tapatalk
 
1 - 6 of 6 Posts
Top