YFZ Central banner
1 - 13 of 13 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Hey everyone, just picked up a mx yfz. It runs fine but is really lean, the curtis sparks lights up bright red and has some popping/backfiring. My mods are listed in my sig. I was hoping someone would have some knowledge/experience with similar mods. I have a ton of time rejetting the banshee so that will be a breeze, I was just wondering a good place to start. I will be riding around 500ft msl, 60-80 degree weather. 170 mains/ 45 pilots good? Any help would be greatly appreciated. Thanks, Chris
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
Alright man I'll give those a shot. I don't have any idea, just got the bike, haven't had the carb off yet. Thanks a lot for the tips
 

·
Registered
Joined
·
301 Posts
I've been reaing a lot on this subject this past weekend due to the fact my bike backfires everytime I let off the throttle. If you have a cam mod done you need to have at least a 48 pilot jet in. I had a 45 in mine. Haven't put the bike back togeather yet so I don't know if it cured the problem.

Jeff
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #5 ·
QUOTE (ntenufsun @ Feb 11 2009, 05:04 PM) index.php?act=findpost&pid=745321
I've been reaing a lot on this subject this past weekend due to the fact my bike backfires everytime I let off the throttle. If you have a cam mod done you need to have at least a 48 pilot jet in. I had a 45 in mine. Haven't put the bike back togeather yet so I don't know if it cured the problem.

Jeff[/b]
I have hotcams in mine, I imagine I will stick a 50 pilot and 178 main in her and see what she does. I'll let you know this weekend how it goes
 

·
Registered
Joined
·
3,780 Posts
the hotcams stage one is basically the same thing as the cam-modded version of the stock cams
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #7 ·

·
Registered
Joined
·
950 Posts
Your sig is huge.
 

·
Registered
Joined
·
3,780 Posts
QUOTE (2001Shee @ Feb 11 2009, 07:41 PM) index.php?act=findpost&pid=745473
what do you have your jets set at?[/b]
umm 3rd clip on needle 160 pilot and a 40 main i beleive. Im at 3500ft above sea level tho

and yea, can you make your sig a bit shorter or downsize your pics
 

·
Registered
Joined
·
9 Posts
I messed with mine for two weeks and then put it on a Dynotech dyno. We ended up making the best power at 46RW with a 45P 175M and the clip at the 3rd position on the NCVQ needle. I am at 300MSL and temps are 70-85 with 55% humidity. Hope it helps but dyno tuning it is a no brainer. I could post my dyno run if you want a look.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #11 ·
Went with a 175 main and 48 pilot this weekend. Runs much better but seems like there is something to be desired. I will probably jump her up to 180 main 50 pilot next weekend and play with the accelerator pump. hope that does the trick, thanks everyone for the tips
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #13 ·
QUOTE (ndevall @ Feb 16 2009, 09:40 AM) index.php?act=findpost&pid=747023
Check out this thread, it might help out some. http://yfz450.theatvchannel.com/invision/i...st&p=681994[/b]
haha yeah thanks for the help man, seems like they just want to get on each other's case more than help people out.. I have the powerbowl that is mentioned in there also. The new jets fixed my noticeably hot EGTs but still seems like the power is not there.. I don't understand, I will keep messing with it this weekend and let you know
 
1 - 13 of 13 Posts
Top