YFZ Central banner
1 - 16 of 16 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
So sometimes its hard to start but when it does it might idle for maybe 10-20 seconds? Then it dies. The header gets so hot its ridiculous and it only takes maybe 15 seconds? Its not the exhaust, not the air filter, not the gas pump, and I put a MSD on it with the map I usually run on the other bike and there wasn't a difference. I'm thinking this could be electrical? I had been switching between no controller over to a Juicebox PRO, over to an MSD. So maybe the mapping on the bike got ****ed up? Maybe a wire got pulled out somewhere? I'm so ****ing lost with this bike right now
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
Alright I'll try that, so I know how to plug the msd into the computer and get the maps up and what not but how exactly would I go about changing the fuel? Also this was happening when I had the MSD off and after I put it on it didn't change anything, So you think just giving it more fuel would help?
 

·
Registered
Joined
·
1,402 Posts
I see your in Eugene, get your bike on the Dyno at Oregon Coast Powersports (OCP) in Winchester Bay. Jeff will get your MSD all set up and its usually only around $75
 

·
Registered
Joined
·
592 Posts
Even when tuned properly, you're going to get a glowing red header. Use a heat shield or high quality wrap to save face on riding pants. Trust me...
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #6 ·
I'm well aware that that the header will get hot and glow. But its getting ridiculously hot within seconds which isn't normal. I have another 2012 yfzr which is running perfectly. The 2013 though isn't running properly at all and I'm at a lose. I don't think it has to do with the MSD at all because I usually have it on the 2012 and it runs great with my map but when i transfer all my Bolt ons over to the 2013 nothing changes
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #7 ·
alright you guys this should help you figure out whats wrong I hope! so when i turn it on it will idle fine for about 5 seconds but itll then start to slow down until it dies. what could cause that?
 

·
Registered
Joined
·
44 Posts
fuel issue maby sounds like the bike is able to preshurize the fuel system but when u start it it cant keep up with it the demand for fuel like a blockage or a crimped line some where or a fuel pump going bad try takeing fuel sysem apart and cleaning it sounds like A issue i had with my camero would start but only for like ten seconds and die ended up being bad fuel pump oh and the fuel pump preshure should be at 47.0 psi acording to my service manual
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #10 ·
alright so when i unplug the pressure sensor it will idle just fine. when i plug it back in though it won't idle. So i swapped it out with another one i had but it didn't change anything. Is there possibly a blockage? I'll pull the hose out and flush some water through it
 

·
Registered
Joined
·
44 Posts
that and allso u could have a cloged fuel filter or a cloged fuel preshure regulator witch is on a little fuel rail above your throttle body it has a screw in top of it check that for a blockadge too ill keep looking threw service mannuale and send stuff as i find it
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #12 ·
so hears a picture i just took. I dont know if you can see but one of the little screws is missing on the bottom of this part. also the bolt next to it looks like there might be some liquid on it? gas possibly. Would this have anything to do with the problem?
 

Attachments

·
Registered
Joined
·
44 Posts
that is your throttle cable cover and maby if i were u take your throttle body out and clean it make shure evrything is working take your injector out and clean it make shure the butterfly valve is clean and moveing freely make shure every thing like the tps sensor it tight and no hoses are pinched all of your electrical conections on the tps sensor air preshure sensor and the injector are clean and conected
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top