YFZ Central banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2,099 Posts
Discussion Starter · #1 ·
I just did a top end rebuild on an 06 yfz with a CP 12.5:1 piston and BB jug. I triple checked the cam timing (has cam mod on exhaust, 13 pins between the dots, hot cams intake cam), made sure it was dead nuts tdc, I have spark, I'm now at a loss as to why it won't start. Next step was starting fluid but I ran out of patience for the day. Plug isn't fouled or soaked.

Also battery was dead... I left the key on... charged that back up to full!

It was torn down due to engine noise. Turned out pin seized in the piston (assuming its due to lack of oil mod which I've already done). This gouged the cylinder up pretty good and the front piston skirt area.

Anything I'm missing? Never had this issue before as its not my first rebuild.
 

·
Registered
Joined
·
2,099 Posts
Discussion Starter · #2 ·
Got it resolved!!! Valve shim moved out of place and was keeping the valve open losing compression...
 

·
Registered
Joined
·
53 Posts
I just did a top end rebuild on an 06 yfz with a CP 12.5:1 piston and BB jug. I triple checked the cam timing (has cam mod on exhaust, 13 pins between the dots, hot cams intake cam), made sure it was dead nuts tdc, I have spark, I'm now at a loss as to why it won't start. Next step was starting fluid but I ran out of patience for the day. Plug isn't fouled or soaked.

Also battery was dead... I left the key on... charged that back up to full!

It was torn down due to engine noise. Turned out pin seized in the piston (assuming its due to lack of oil mod which I've already done). This gouged the cylinder up pretty good and the front piston skirt area.

Anything I'm missing? Never had this issue before as its not my first rebuild.
We have the same build
 
1 - 8 of 8 Posts
Top