YFZ Central banner
1 - 11 of 11 Posts

·
Registered
Joined
·
336 Posts
Discussion Starter · #1 ·
Alright all you mechnics, heres my ordeal...... went out riding today and I've lost some top end speed. It ran great the last time I was out. Since my last ride the only things I have changed is (1) installed a motion pro throttle. (2) cleaned and reoiled my air filter.

I checked to make sure my throttle was opening up all the way cause I thought I might not have ajusted the cable properly but it is opening all the way.

my second guess was that I may have put to much filter oil on the filter which is causing it to choke on top. So i removed the air box lid and ran it around to see if that helped and it felt a little better.

so what do you think could a clogged filter cause you to lose top end, cause it seems fine on the bottom end????????
 

·
Registered
Joined
·
264 Posts
To much oil on a filter is almost as bad as a dirty filter. Wrap it in a couple paper towels and see if you can soak up some of the oil. Depending on what you used for oil,, some is so thick you have to wipe it off it's more like grease than oil. Try it see if it's any better. When you get some extra cash get a k&n kit with outer wear. The dirt practically hits the outerwear and falls off. I just clean the outerwear in the sink with dish soap and the filter hardly ever gets dirty.
 

·
Registered
Joined
·
773 Posts
That filter full of oil is more than likely causing a rich condition. Not enough air in combination w/ your fuel intake. Personally, I go real light on oiling filters.
 

·
Registered
Joined
·
773 Posts
Originally posted by RESCUE YFZ@Nov 9 2003, 10:16 AM
so would a rich condition cause me to lose my top end speed?
For sure. When you get through this current problem and your bike's running fine. Replace the main with something several steps/sizes larger and go ride up the street or somewhere you can really gas it. You'll find that higher in the RPM scale, you just sort of loose your umph - flatten out.
 

·
Registered
Joined
·
773 Posts
Originally posted by RESCUE YFZ@Nov 9 2003, 02:52 PM
THANKS FOR YOUR HELP SELECTOR
Did it work?
 

·
Registered
Joined
·
773 Posts
Originally posted by RESCUE YFZ@Nov 9 2003, 03:57 PM
I'm at work so I dont know yet but I will try it out on monday.
Please post your findings.
 

·
Registered
Joined
·
2,629 Posts
and dont' forget too much oil in the filter is still ALOT better than none at all.

Sometimes after a few WOT runs, any excess oil will be sucked through the filter and through the engine, in affect unclogging the filter of excess oil.

what type of filter oil did you use?
 

·
Registered
Joined
·
5,829 Posts
Ok by now you have to have ridden this thing and know if it is better or not.
 
1 - 11 of 11 Posts
Top