YFZ Central banner

1 - 18 of 18 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi guys. First post in a very long time. I could not remember my old username and password so I had to start a new one. I have a 2006 model that has been sitting for several years. I got it back up and running very well on flat ground so I took it to the Mx track.
Upon hitting rough terrain, occasionally on the face of the jumps, or in the air, the bike was acting as if the fuel or key was being shut off. It would either almost die or completely die in the air. Even after I land that I could stab the gas and there was nothing for a second or two and then it would take off again. It’s never done this before. Carb is clean and everything is fresh on the motor. Only thing that I have done different is I have the boysen quick shot 2 installed. It doesn’t make sense that this would be a problem, if anything it should fix it however considering I about killed myself today taking off on a large jump only for it to die at the top and me coming up short, I’m ready to switch it back. Does anybody have any other ideas? Thanks
 

·
Registered
Joined
·
10 Posts
Hi guys. First post in a very long time. I could not remember my old username and password so I had to start a new one. I have a 2006 model that has been sitting for several years. I got it back up and running very well on flat ground so I took it to the Mx track.
Upon hitting rough terrain, occasionally on the face of the jumps, or in the air, the bike was acting as if the fuel or key was being shut off. It would either almost die or completely die in the air. Even after I land that I could stab the gas and there was nothing for a second or two and then it would take off again. It’s never done this before. Carb is clean and everything is fresh on the motor. Only thing that I have done different is I have the boysen quick shot 2 installed. It doesn’t make sense that this would be a problem, if anything it should fix it however considering I about killed myself today taking off on a large jump only for it to die at the top and me coming up short, I’m ready to switch it back. Does anybody have any other ideas? Thanks
Hi guys. First post in a very long time. I could not remember my old username and password so I had to start a new one. I have a 2006 model that has been sitting for several years. I got it back up and running very well on flat ground so I took it to the Mx track.
Upon hitting rough terrain, occasionally on the face of the jumps, or in the air, the bike was acting as if the fuel or key was being shut off. It would either almost die or completely die in the air. Even after I land that I could stab the gas and there was nothing for a second or two and then it would take off again. It’s never done this before. Carb is clean and everything is fresh on the motor. Only thing that I have done different is I have the boysen quick shot 2 installed. It doesn’t make sense that this would be a problem, if anything it should fix it however considering I about killed myself today taking off on a large jump only for it to die at the top and me coming up short, I’m ready to switch it back. Does anybody have any other ideas? Thanks
I also have t he 2006 yfz and yz450f. I had a similar problem with the YZ if I hit whoops jumps it would cut out like fuel or electrical. After I replaced many things it turned out to be a dirty mid body on the FCR carb that was causing it. If you can bounce up and down on it during idle and it’ll start to stall I’d bet some $ it’s a dirty mid body. There’s an aftermarket mid body rebuild for like $20 well worth the money. I also got rid of my K&N and went back to foam to catch the fine dust in AZ. Hope that helps!
 

·
Registered
Joined
·
10 Posts
I also have t he 2006 yfz and yz450f. I had a similar problem with the YZ if I hit whoops jumps it would cut out like fuel or electrical. After I replaced many things it turned out to be a dirty mid body on the FCR carb that was causing it. If you can bounce up and down on it during idle and it’ll start to stall I’d bet some $ it’s a dirty mid body. There’s an aftermarket mid body rebuild for like $20 well worth the money. I also got rid of my K&N and went back to foam to catch the fine dust in AZ. Hope that helps!
I also changed the gas cap and it didn’t fix it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
@[email protected] funny you say that. I pulled mine apart and noticed that middle gasket looked to be in poor shape so I ordered a new one and I will have it here Friday. Hopefully that solves the issue. It looked a little mushy
 

·
Registered
Joined
·
10 Posts
@[email protected] well I’m here at the track right now. Mid body gaskets replaced and now it is trying to cut off upon landing. I’m at a freaking loss...
Do you think the mid body gasket changed the symptoms? Wondering if there’s a bit of grime inside or moved around from the cleaning. If you have a buddy with same bike I’d switch carbs to see if it continues before replacing things. I replaced everything on my bike (stator, harness, flywheel, plug, gas cap, breather tube, computer) before fixing it with the mid body kit.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Do you think the mid body gasket changed the symptoms? Wondering if there’s a bit of grime inside or moved around from the cleaning. If you have a buddy with same bike I’d switch carbs to see if it continues before replacing things. I replaced everything on my bike (stator, harness, flywheel, plug, gas cap, breather tube, computer) before fixing it with the mid body kit.
The inside of this thing is spotless. I’m at a loss. I completely tore it down once again. Every single piece and put it back together. Same issue. I’m losing my cool
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
Opened up the mid body carb again And I think those were poor fitting gaskets. I’m going to return them even though I already ran them because they we’re so off. I just ordered from all balls
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
When I first installed them they weren’t quite perfect but they were so close that I got them into the groove and held them there with a touch of Greece however they obviously back out. I almost thought about just making my own gasket
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15
If the all balls kit doesn’t work i’m going to put some 556 through it and just get a new one😁
 
1 - 18 of 18 Posts
Top