YFZ Central banner

1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
let me start my saying that the cam mod is almost useless...the amount of power increase ,if any,is not worth the aggrevation...i did this mod and i was slower..i tried every jet ,needle combo and nothing worked...my exaust also turned cherry red at idle!!!can someone tell me why?i went clockwise one tooth...it was hard starting and no power up top...i know about the decompression and all that...did i go the wrong way?i put it back to stock and it runs like a champ...has anyone had better success and does this mod make a significant difference?
 

·
Registered
Joined
·
634 Posts
The cam mod worked very well for us twice when we finally jetted right. even our dealer said it had a lot more power when he heard it rev.

we had a pipe GYTR and and GYTR foam air filter and the pilot 48 and the main jet was 175 and the needle was on clip #4 from the FAT end.
and the air screw was on 1.5 or so

we had the GYTR NEEDLE # NCVQ

I believe your problem may have been jetting, when the pipe is red you are very lean, then you may not get power.
we are at 1000 feet. at 70 degrees.

everyone else is doing the mod well, and there is a big difference when you do it.

here is a video of the quad we ran against a stock 450

www.eskimo.com/~daddog/videos/modunmo.wmv

I am not sure of your problem, you may want to have someone who succesfully set one up with the cam mod try it and jet it.

But the cam mod works very well and you get a lot of power.
 

·
Registered
Joined
·
5,829 Posts
You must have done something wrong because with the mod it should gain 2-4 HP with correct jetting. Did you up your pilot jet and adjust the mixture screw along with your main and needle changes?
 
1 - 4 of 4 Posts
Top