YFZ Central banner

1 - 20 of 21 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
FIRST QUESTION What are the years that are interchangeable with each other for the ecm's?

Took bike up to local yamaha dealer and had them hook up scan tool and read the codes and said that every code was popping up.. And they said they cleared it to see maybe if it would just pull up one trouble code and it did the same thing so they said that it was the ecu.... I bought the bike not running.. I reset timing and re shimmed the valves and new timing chain and new ngk plug new fuel new oil Yada Yada.. Went to start the bike nothing checked spark its has good blue spark... Fuel pump primes starter cranks engine over fine... If I pull the plug and pour a Lil fuel down in the cylinder and put it back together it will fire it... But it's not receiving fuel from injector... Does anyone have have any input on what they think... I chalked it up to the rollover switch or the ecu but idk I have never had an efi 450 just carb models.
 

·
Registered
Joined
·
282 Posts
I think the ecu from 09-13 is one part number, and 14-present are another. 14 and newer have the air injection crap.

Have you tried disassembling the tip over sensor and gluing it in place? This would eliminate the sensor, but also eliminate that as an issue.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Alright I need some help here.... I changed ecu from a running quad... Still nothing same symtoms turns over doesn't start... Glued tip over switch.... Still same thing... Changed coil... Same thing put a new oem injector in it because old one was dirty... And I'm for sure it's getting getting fuel... I have ran ohm tests on every other sensor on this bike the way Clymer manual says to... Has new battery.... Not blinking any engine codes.... But this bike will not run... I can manually pull spark plug and spray a Lil fuel into cylinder and it will fire it but it will not run... I have no clue what the issue could be... I went as far as rechecking my valve clearances and timing and still the Same issue.... If anyone could give me shed some light on this turd lol I'd sure appreciate it.
 

·
Registered
Joined
·
477 Posts

I’m experiencing a similar issue but I have no spark. I’ve narrowed it down to one of the four on that list. Could be ignition coil is bad even though it’s testing good. Damaged spark plug cap. Or I sheared a woodruff key. Yours might be your tps or injector. Anything else should/would throw a fault code/CEL.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Thanks orange.... A buddy and I were talking about it today and I have heard stories that if the electrical system does not maintain a certain voltage that it would not allow the injector and coil to fire at the right time... So I think I'm just gonna throw a new rectifier and stator and crank position sensor in it for piece of mind if that doesn't work I am gonna rip off all the efi crap and carb this bastard ?
 

·
Registered
Joined
·
477 Posts
Yes you can. As long as the ECU is from a fuel injected model. Your ais will no longer work which I would consider a good thing. Just remove the ais.

Your question is kinda confusing. I think you mean putting a 2012 ECU on a 2019 450R but you worded it backwards. If your trying to put a 2019 ECU on a 2012 450R that isn’t going to work like atvman said. It will run like crap.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
28 Posts
I live in JOPLIN MO AREA, anyone with a 09-13 450r want to help me with checking ECU, I have my original 12, and the 19 ecu, it try’s to run better with the 19 ecu, but not right.
 

·
Registered
Joined
·
477 Posts
Yes I have 2012 and I am trying to use a 2019 ECU, will this not work?


Nope it will run like crap and there’s nothing you can do about it. There is emissions control embedded in the 2014+ ECU which controls the AIS. It can’t be overridden or erased. Get yourself one from 09-13 and you’ll be back in business.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
477 Posts
I live in JOPLIN MO AREA, anyone with a 09-13 450r want to help me with checking ECU, I have my original 12, and the 19 ecu, it try’s to run better with the 19 ecu, but not right.


Are you the original owner? If it happens to have aftermarket cams in it with a stock ECU it will run like crap or not at all.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
28 Posts
The 2019 ECU will allow the bike start but it will not throttle and rev correctly, 09-13, interchange, 14-15interchange, 16-19 interchangeable,
 

·
Registered
Joined
·
2 Posts
FIRST QUESTION What are the years that are interchangeable with each other for the ecm's?

Took bike up to local yamaha dealer and had them hook up scan tool and read the codes and said that every code was popping up.. And they said they cleared it to see maybe if it would just pull up one trouble code and it did the same thing so they said that it was the ecu.... I bought the bike not running.. I reset timing and re shimmed the valves and new timing chain and new ngk plug new fuel new oil Yada Yada.. Went to start the bike nothing checked spark its has good blue spark... Fuel pump primes starter cranks engine over fine... If I pull the plug and pour a Lil fuel down in the cylinder and put it back together it will fire it... But it's not receiving fuel from injector... Does anyone have have any input on what they think... I chalked it up to the rollover switch or the ecu but idk I have never had an efi 450 just carb models.
did you ever find out what the problem is? I’m having the same exact problem!! Any advise would help!! Thanks
 
1 - 20 of 21 Posts
Top