YFZ Central banner
1 - 3 of 3 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi Guys

newbie here but not new to bikes.

Bought a 2006 YFZ450 that someone had hacked the wiring harness about on and was a right mess.
They’ve also converted the thumb throttle to a normal twist grip throttle removing the thumb throttle switch.

Ive fitted a new wiring harness, reg/rec and stator as old one was toast.

it’s missing the throttle switch wiring and clutch switch wiring.

neutral light will only illuminate when grounded to the frame.

it was turning over and sparking only when the grey push button is held down. It will run all day with the button held down but obviously this will burn out the starter motor and starter clutch assembly if I were to keep it held down while riding.

any ideas on where to look at?

also where is the frame ground?

there’s a ground built into the wiring harness from the negative - side of the battery but can’t seem find a frame ground.
Thanks
 

· Registered
Joined
·
6 Posts
I have a 2004 YFZ that had the same exact issue. Mine had a brand new wiring harness because the guy I got it from couldn't solve the problem. There is a little black wire that comes from the harness by the battery. Mine had a female connector on it and it went to nowhere. It would start and die. But run with the start button held. I clipped the female connecter and grounded it to the battery. Bike runs perfect now. Also my TORS is unplugged. TPS is bypassed. Also try taking your fuel cap off it could be creating vacuum lock in the tank not letting fuel flow. Hope this helps!
 
1 - 3 of 3 Posts
Top